Need Help with Home Network (windoze 10)

Didn’t know where this should go, so I put it here…

For 3 years I had a WD MyCloud NAS drive on my network. Worked great - accessible by all computers/laptops/phones/tablets in the house (and remotely).
The control card in the unit crapped out last week and got a new EX2 Ultra, 2 bay NAS.

Set it up and it looks good - able to access files on the drive from computer (wired), phones, tablets EXCEPT not the laptop - either through wifi, or plugged into the router.

When I go into file explorer and click on “Network”, the drive does not show up like it does on the computer (both Win10), where I can open up the directories/files.
It DOES show up as a “Storage” device in the right widow pane, but when I click on the icon, it opens up the devices dashboard.

Any help much appreciated.

Probably need to map your NAS to a drive letter.

Click on Map Network Drive. Then you’ll need to know the device name or it’s IP address. So the path would be like




Assuming the root folder of the NAS is accessible.

Stupid forum software. The beginning of the path should have two left slashes \\DeviceName\ etc

Hey, that worked… thanks.
Weird that it doesn’t show up under Network or Homegroup.

Make sure to click on the “Reconnect at logon” button.

It probably has something to do with your Network Discovery settings, or the workgroup on the NAS could be set to something other than the default of workgroup or the same for your computer. Could be several things.

Change the default admin console password too.